安装Linux服务器安全狗出错的解决方法

linux安装安全狗时提示Need system command 'locate' to install safedog for linux以及Need system command 'lspci' to install safedog for linux的解决方法

安装网站安全狗(以64位为例)

使用wget方式下载发布包:wget http://down.safedog.cn/safedog_linux64.tar.gz

在root 帐户下执行以下命令:

tar xzvf safedog_linux64.tar.gz(在这里一定要看解压后的路径,否则会无法进入目录,如上图)

cd safedog_an_linux64_2.8.21076

chmod +x *.py

./install.py

输入命令后,提示

Need system command 'locate' to install safedog for linux.

Installation aborted!

这个问题是缺少搜索命令组件

运行

yum -y install mlocate

然后重新安装

就OK了,非常简单。

如果再次安装又提示

Need system command 'lspci' to install safedog for linux.

Installation aborted!

原因是lspci未安装,lspci不能使用,安装记录下。

yum -y install pciutils

点赞

发表评论

电子邮件地址不会被公开。必填项已用 * 标注